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This tutorial will instruct you on how to use the Keil Microsoft Windows based software devel opment
tools with the Siemens C504 based evaluation board. This tutorial will also provide general information
regarding any C500 or 8051 microcontroller. The source code for this application note can be found in
file 113.zip on this CD.

For more information you may visit these Web sites:

http://www.keil.com - main Keil Software web page.
http://lwww.keil.com/~market - Technical Marketing page and errata to this document.
http:/www.siemens.com - main USA Siemens web page. See www.siemens.de for Germany.
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INTRODUCTION

The Siemens C504 uses a 8051 core and is targeted to AC/DC motor control applications. The entire
Siemens C500 microcontroller line is fully supported by the Keil Tool Chain. ThisincludesaC
Compiler, Macro Assembler, Code Banking Linker/Locator, nVision IDE and the dScope Simulator.

The Keil Tool Chain supports all In-circuit emulators that support the Intel OMF51 debugging
specification. The Keil OH51 Object to Hex Converter converts an absolute object file into an Intel
HEX file and is suitable for programming into an Eprom.

The Keil tool chain consists of the following executables:

nVision uvwble.exe
C Compiler  C5l.exe
Assembler A51l.exe

Linker bl51.exe
Converter oh51.exe
dScope dsw51.exe

These files are located in the c:\c51eval\bin directory for the evaluation version. Thefull versionis
located in the c:\c51\bin directory. They are DOS programs. Access to these programs from Windows
is accomplished with nVision. The entire tool set can be run from mVision or directly from DOS. The
Evauation version islimited in code size to 2Kbytes. The starting address must be greater than
0x4000. Other than these restrictions, all features operate normally.

nVision IDE

nVision is a Windows based front end for the C Compiler and Assembler. It was developed in the USA
as were the printed manual set. Compiler, Assembler and Linker options are set with simple mouse
clicks. mVision runs on Windows 3.1, 95 and NT. This Integrated Devel opment Environment (IDE) has
been expresdy designed with the user in mind. A full function editor isincluded. All IDE functions are
intuitive via pull down menus with prompted selections. An extensive Help utility isincluded. Externa
executables can be run from within mVision. Thisincludes emulator software.

C51 C Compiler for the entire 8051 Family including the Siemens C500 Family

The C51 ANSI compiler with the A51 assembler are designed specifically for the 8051 microcontroller
family, including the C500 series. The C51 is 100% compatible with existing 8051 programs. C51
supports code banking. The compiler can be run in either DOS mode or called from the Windows based
front end nVision.

A51 Macro Assembler

This Macro Assembler isincluded with each Compiler package or is available separately. All utilities
needed to complete your project are included for all members of the 251 family. This Assembler is
DOS based or can be run from nVision which isincluded with every Assembler and Compiler package
available from Keil Software.



BL51 Code Banking Linker/Locator

The BL51 Linker/Locator is used to join rel ocatable object modules and library files together. The
object files were created with the C51 compiler or the A51 Assembler and the library files are provided
by Kell. This process results in absolute object modules. The BL51 is DOS based and can be run from
DOS or through Windows using nVision. A MAP fileis aso produced giving details of the memory
structure. This object file may be specified to contain debugging information as required by simulators,
debuggers and emulators. The BL51 can overlay important internal RAM for variablesto greatly
increase the speed of processing.

OH51 Object Hex Converter

The Keil OH51 Object to Hex Converter converts an absolute object file produced by the BL51Banking
Linker into astandard Intel HEX file. Thisfileis suitable for programming into an Eprom or as an
input to an emulator. OH51 isa DOS file and can be called as such with suitable argument(s) or run by
nVision.

dScope Simulator

dScope is a software smulator. Y our code can be debugged either in software on your PC or in your
target hardware. When operated in conjunction with the Keil monitor installed in your target hardware,
dScope becomes tScope. Y ou have the ability to run/halt, set breakpoints, examine/change memory,
view the stack, view/set peripheral information and apply virtual external signals. dScope hasa
Performance Analysis feature to ensure your code runs efficiently. dScope hasa
disassembler/assembler allowing you to make changes in your code without recompiling.

The evaluation version of the Keil tool set isrestricted to a 2K code size and the code must be located at
0x4000. Useful object codeis produced. Other than these restrictions, the tool set works exactly as the
full version does. Thisalowsyou to fully evaluate the features and power of Keil products. The full
version has no restrictions and is fully ANSI compliant.

ABOUT THIS TUTORIAL

Thistutoria consists of severa sessionsillustrating the features of the Kell Tool Set. The C language
program shown above will be compiled and run using various features of the Keil C51 Tool Set. The
focusison using Keil’s mVision integrated devel opment environment. It explains how to create and
build a new project using a source code example provided in this tutorial.

The following steps below show you how to configure the tools, assemble and link the code, and invoke
the debugger, dScope. Before you begin this tutorial, you need the Keil software development tools.
The Evaluation version is on the Siemens CD ROM or is available from the Web: www.keil.com. You
may need an update disk to update nVisionto 1.24. Cal Kell if thisis not on the Semens disk. Or
check www.keil.com/~market.

STARTING THE TUTORIAL

Installing the Keil Software
Ingtall the Keil Software development tools by completing the following steps.

After you install the Keil development tools to Windows 3.11, aKeil program group or icons appears
on your desktop. (the Windows 95 version is shown in Figure 1). Recall dScopeisthe Keil Simulator
and nVision is the Kell Windows based user interface (or IDE = Integrated Development Environment).



FIGURE 1

For Windows 95 you must ingtall the two icons manually asfollows. If thetwo iconsarevisibleina
small window drag them onto the desktop. If they are not visible, follow these instructions:

1) right mouse click while in the Desktop

2) select New/Shortcut

3) The executable file you want to enter asthe Command Lineis c:\c5leval\bin\uvw51e.exe
4) Thesuggested nameism/ision.

5) Repest this process for c:\c51eval\bin\dsw51.exe and name it dScope.

The full version of the software installs these icons to the Windows 95 desktop.

Starting the Software:

Double-click on the nVision icon to start the user interface. The compiler, assembler, linker and
dScope will be caled from within mVision in thistutorial. After you invoke nVision, the window
shown in Figure 2 appears. From thiswindow, you can create projects, edit files, configure the tool,
assemble, link, and invoke the debugger. Other 3 party software such as emulators can al'so be started
from here.

i Y .. g evalualion

|Vision evaluation for Windows [ [ Nw [

FIGURE 2



CREATING A NEW PROJECT

1. Open the Project menu and choose New Project. The window shown in Figure 3a appears except
that *.prj shows under File name instead of newp.prj.

2. Enter the name of the project you are creating. For thistutorial, enter the name newp.prj and press
OK. Newp.prj will be entered under File name: as shown in Figure 3a. Figure 3b will open up.

Open Project |

File name: Folders:
Im c:ichlewvalibin
Cancel I
- et -
£5 chleval Metwork.._. I
3 bin
e
e
List hles of type: Drives:
Project File [*.prj) _‘j I = ¢ micron ;]
FIGURE 3a
Project - C:ACS1EVAL\BIMN\NE'WP.PRJ
Source Files
Add | Save |
Hemove | Cancel I
Move Up | Help I
Moye Fown |
[pen | penAll |
Translator: | ﬂ| Command: i
7 Alwayps Build. [ Include in Link/Lib thBClil
i . I Eatal Error I Warning
I™ Execulc Bank number: eror level ermror level error level

FIGURE 3b

Thiswindow is used to add various files to your project. Theseinclude ASCII files, C and assembly
source and macros. Thelist is quite extensive and is found in the Trandator window if any files are
present in the project. Note thiswindow is blanked out at thistime. Thiswindow is accessible at any
time by selecting Project/Edit Project and you may easily edit your filelist. Note that any assembler
filesmust belast inthislist. If they are not, changes made to them will not be reflected in the fina
object file.

When creating a new project in this manner no source files are yet available. Therefore, select save to
close thiswindow. Y our project newp.prj will be active. Click on Project and confirm newp.prj is
visible at the bottom of this pull down menu.

CREATING A NEW SOURCE CODE FILE



1) Open the File menu and choose New to go to the integrated editor. If you aready have the source
listing, choose Load instead.

2) An editor window appearsin the nVision window. Use the editor to type in the example program in
Figure 5. Thissimple program uses anumber of C instructions to demonstrate various functions of
the C504. Another program is used to demonstrate the Performance Analysis function. The source
code and project files are included with this application note.

3. After you finish typing the code, open the File menu and choose Save. The window shownin
Figure 4 appears.

4. Select the directory where you saved the project. Thistutorial usesthe directory: c:\c5leval\bin

5. Enter the name of the file you are saving and press OK. Thistutoria usesthe name: demo.c.

6. At thispoint you have created a project called newp.prj and a C source file called demo.c.

The next step isto build your project. Thisincludes compiling (not done here), assembling, linking and
locating and creating the hex file.

Save As
File name: Folders:
E c:hchlevalibin

— __ Concel |
- C: =
%8518?6“ Network.... i
in

Save hle as lype: Drives:
C Source [*.c) _‘j | =) ¢ micron LI
Figure 4



/* Siemens C504 example - Robert Boys, Copyright 1997 Keil Software Dallas, Texas */
/* This is a simple program used to demonstrate the Keil debugger dScope */

#i ncl ude <reg51. h> /* declare 8051 SFRs */
#i ncl ude <stdio. h> /* not -really- needed, but here it is anyhow ! */
int var = 1; /* declare an integer variable to be pointed to */
int *ptr; /* declare a pointer to point to an integer */
voi d stepout(int Q) /* declare a sinple function called stepout */
/* does not really do nuch but denobnstrate the */
int count; /* stepout, stepin and stepover functions of dScope */

int total = 0;

for (count = 1; count <= 10; count++)
q =92
}
struct cord { /* declare the structure named cord */
int Xx; /* with nenber variables x and y */
int y;
} first, second; /* declare two structures with menbers x and y */
voi d mai n(void) { /* start of the main programhere */
int b =0; /* declare a few integer local variables */
int count = O;
| ong bigcount = O;
ptr = &var; /* declare ptr to point to the variable var */
* - -
ptr = 3;
first.x = 5; /* and initialize them */
first.y = 5;
second. x = 2;
second.y = 2;
while(1) { /* start an endl ess | oop here */
first.x++; /* increnent all the pointers */
second. y++; /* just for something to do */
first.y++;
second. x++;
count ++; /* increnent this thing while we are here */
st epout (b); /* pay a visit to the function for atime */
bi gcount =bi gcount +2; /* add two to this long variable */
*ptr=*ptr*3; /* multiply var by three using its pointer */
}

Figure 5. Example Program



BUILDING THE PROJECT

Open the Options menu and choose Make.
Click on After Make. The window shown in Figure 6 appears.

1)
2)
3)

Make sure Run dScope Simulator/Debugger deselected and click on OK. The debugger will not

run at the conclusion of the Make utility. If you prefer to invoke the debugger automatically, leave
this selected later. Y ou can look under some of the other tabs to see some of the options that can be

set but do not change anything from the defaults at thistime.

Make Options [NEWFP.PRJ] E3
After Compile I After Make r Misc T Extensions ]
—After Make
[" Run user program 1: Cancel |
I Browse. I
Help
[" Run user program 2: .—]
I Browse.. | Default |
[ ‘Run dScope Simulator/Debugger:
[ Download to PROROM Eprom Emulator
FIGURE 6

4) Open the Project menu and choose Edit Project. The window shown in Figure 7 appears. Thisis
where you add various filesto your project. Note there are no filesin the project yet.

Project - C:ACH1EVALABINANEWP.PRJ
Source Files

add | [ save |

Hemove | Cancel I

Move Up | Help I

Mioye [Yown |
[pen | penAll |
Translator: | ﬂ| Command: i
7 Alwayps Build. [ Include in Link/Lib thBClil
I™ Exceutc Bank number: l_ enEO?lI:Ivel Bll%l' rI':t'erwml I_ e\:v_r:r' rI.niar\:'%l
FIGURE 7

5) Choose Add. The window shown in Figure 8 appears. Thisiswhere you add the files to your

project.



Add File to Project EHE

File name: Folders:
Iﬁ c:hchlevalibin
LCloze ]
demo.c - [ =
-.‘@ chleval Network. .. I
£ bin
List files of type: Drives:
C Source [*.c) _'J I = c: micron :J
FIGURE 8

6) Make sureyou arein the correct directory: c:\c51eval\bin.
7) Seect thefile: demo.c and press Enter.
8) Choose Add then Close. DEMO.C will belisted in the Source Files window.

9) Click on Always Build so thisis activated. This feature forces abuild of the selected file if an
UPDATE (rather than the full build) is done even if thisfile has never been modified since the last
build. Include in Link/Lib should also be active.

10) Choose Save.

CONFIGURING THE MAKE UTILITY, COMPILER, AND LINKER

Keil Software has aMake utility that can compile and link C and/or assembly coded files. It also has
other configuration and default setting features. Before using the make utility, configure the make
options. Make the changes asindicated and |eave al other options set to their default values. nVision
allows you to set various options with mouse clicks and these are all saved in your project file.

1) Configure the Make utility.
Open the Options menu and choose Make.
Configure the options in the window as shown in Figure 9 and press OK.

Make Options [NEWFP_FPRJ)

~After Compile
" Stop
_ Cancel I
* Run BL51 Banked Linker
" Run LIB51 Librarian Help I
™ Bun DC51 Object Converter Default I

¥ Bun DH51 Object Hex Converter

FIGURE 9
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2) Configure the Compiler.

Open the Options menu and choose C51 Compiler. Note the Command line options string.

Configure the options in the window under Object as shown in Figure 10 and press OK. Select
Include symbols under the Listing tab.

NOTE: if you use the assembler (we will not in this tutorial) you will want to turn on the debug
information (include debug information) under the Object tab under A51 Assembler.

C51 Compiler Options [NEWP_PRJ]

Listing |
™ Keep variables in order

¥ Include debug information

¥ Include extended debug information ﬂ‘
[ Generate 80C517 code Help I

¥ Enable AMSI integer promotion rules

[~ Generate Registerbank Independent Code m

 Interrupt Yectors

™ Include in object  Interval iB Offset: il]

Command Line Options String

DB OE |j

FIGURE 10

T Optimization T Memory Model T Misc ]

3) Configure the Linker.
Open the Options menu and choose BL51 Code Banking Linker and choose the Linking tab.
Configure the options in the window as shown in Figure 11 and press OK.
Y ou can view the other tabs but leave everything set to the default values.

BL51 Code Banking Linker [NEWP_PRJ]

Listing | g[ SizefLocation T Additional T Segments r Files ]
i~ Debug Information ——— ~ Target Options

v Include local symbols [ Code banking
Cancel |

v Include public symbols [ RTX51

 Include line numbers [~ RIX51 tiny &]
: : Default |

[ Ignore default hibraries

¥ Enable variable overlaying

Command Line Options String

RS5[128) PL(68) PW(78) E

FIGURE 11
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4) Additional Notes:

You must have a directory called c:\tmp on your hard drive. Thisis created by Windows during its
installation and is used by Keil for storing temporary files.

COMPILING THE CODE AND CREATING AN EXECUTABLE FILE

Once you have configured the tool, you are ready to run the compiler and linker using the Make utility.
We will not be using the assembler for thistutorial.

1. Click onthe Build All icon (it has three arrows pointing downwards) or open Options and select
Make.

2. If the program specified (demo.c) contains any errors, they will be shown on the screen.

If there are no errors, the code is assembled and linked and the executable code is ready to be
downloaded to the board. The code to be downloaded to the board will be the name of the project
with no filename extension. In this case thiswill be newp. Click on OK in the Project Status
diaog box and continue to the next section. Note aHEX file has been created. Other files are
created to help the debugging process.

If alist of errors appears, use the editor to correct the error(s) in the source code and save thefile.
Then, repeat this section: beginning at step 1.

DOWNLOADING THE CODE TO THE C504 EVALUATION BOARD

Y ou are now ready to run the dScope debugger to download code to the evauation board.

Connect the seria cable from a COM port on your PC to the 9 Pin serid port X4 on the Phytec board.
Supply regulated 5 voltsto X2 & X5 on the board. Please carefully apply the correct polarity.

Use the default board jumper locations.

Click on the debugger icon on the nVision toolbar. Thisiconisa“d” seen through a magnifying glass
and isyellow and bluein colour. Thisisthe sameiconinstaled for dScope in your desktop area. If you
leave the mouse pointer on an icon for afew seconds, the word “debug” will appear. A window similar
to that shown in Figure 12 isdisplayed. Y ou may want to move and resize the windows. The window
marked “Module: <none>"" is the Debug window. The Command window can be used to enter
commands. It will not be used during this portion of the tutorial.

Y ou may need to open, resize and /or move some windows to make your screen look something like
Figure 12. The Debug, Memory, Watch, Command and Regs windows will be used. Y ou may want to
open the Commands menu in the Debug Window and select Show Toolbar.

12
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FIGURE 12
INTERFACE SETUP

Before you can load the executable file to the debugging environment and to the evaluation board, make
sure you have the correct driver and interface. dScope is a software debugger and smulator. tScopeis
the debugger but connected to a hardware system. Programs are run on the target hardware rather than
in the virtual microcontroller in your PC. The Kell debugger tScope will communicate with the monitor
contained in the FLASH memory on the evaluation board. For additiona or updated monitor software,
contact Keil Software.

The upper left hand corner of Figure 12 shows that dScope is active in this case. Thiswill change to
tScope if the appropriate dll (i.e. mon51.dll) is chosen. If you select 8051.dll, you will get dScope.
Y our ssimulation will not be run on the board but in your PC as aready stated.

1) To establish communication with the evaluation board, choose the correct driver using the pulldown
list on the left portion of the debugger toolbar. In this example, mon51.dll is chosen.

2) mon5Ll.dll: When the serial link is connected and the mon51.dll is selected dScope will try and
communicate with the kernel located in the FLASH memory on the board. tScope should be
displayed in the upper left hand corner. If you get thisfar, things are working properly.

3) If you open the View menu and select Command Window, you can type commandsin here. If you
type help - you will get an error message returned. This confirms the monitor isworking.

4) Thiswill happen only if communication is established. |f the wrong COM port or speed is selected

aNo Target System Found ! dialog box will open. The correct speed for a40 Mhz crysta is
19,200. If this happens; follow the instructions under Communications Setup.



COMMUNICATIONS SETUP

Y ou need to follow these instructions if proper communication was not established. After a series of
attempts dScope will error out asindicated in the No Target System Found ! dialog box.

Select the appropriate configuration.. Select the appropriate COM port for your system. The speed
must be 19,200 for the 40 Mhz crystal. For the 20 Mhz version, select 9600 if 19,200 does not work..

After you set the COM port and baud rate correctly, click on Try Again.
LOADING THE EXECUTABLE FILE TO THE DEBUGGER ENVIRONMENT

1)
2)

3)

4)

5)

Open the File menu and choose Load Object file.

In the Window provided, select the file: newp. Thefileis downloaded to the board and the
debugger. You will see the source code see the code on your screen. Note with some code, you
might not see your source code because the program starts at 002000H which is a condition of the
evaluation version of the Keil Compiler. Y ou may see the LIMP instruction at C:0000H. The full
version of the Kell Toolset will start at 0x0000 or wherever you set it.

If necessary, to see the code enter the following command in the Command window; $=0x201F
Note: this command sets the Program Counter ($) to hex 201F. Y ou can also use the command
$=main if you prefer. The program counter will advance to main. Note you can press the up
arrow key to get the history of keys typed in the Command Window.

To see the Command window if not already visible, select View/Command Window. To seethe
source code, select the Debug window in the same fashion.

Y ou should now see the source in the Debug window as in Figure 13 depending on how you set
your windows. Y ou can single step using the Stepinto icon. Y ou are now ready to use the dScope
window (really tScope) to step through code, set breakpoints, and issue the Go command to start
program execution. Y ou can examine special function registers, memory locations, and register
values, etc.

14
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SAMPLE SESSIONS

Breakpoints

Click on amemory location such as line number 42 first.xx++ and a colored bar appears marking
this position.

You could click on Go Til Curs! to reach this point or you could double-click and a breakpoint is
set. Set abreakpoint here with the double click. The [BRO] indicates the first breakpoint.

Click on GO and the program will run and stop at the breakpoint.

Double click on the breakpoint to removeit.

In Line Assembler

Open the Commands option and click on Inline Assembler or if Show Dialogbar is active, click on
the Assembl e button in the Debug window.

The Inline Assembler windows opens asin Figure 14.

Note that you could enter mnemonicsin the window titled enter MCS-51 instruction: Do not do
this at thistime. Just note the ability to make small changesin the program without recompiling the
program.

Click on Close.



Inline Assembler

— dizsassembly:

c:0x201F clr a
c:0x2020 mov Dx15.a
c:0x2022 mov 0x16.a
c:0x2024 mov Dx17.a
c:0x2026 mov 0x18.a
c:0x2028 mov Dxlc.a
c:0x20Z2a mov Oxlb.a
c:0x202c mov DOxla.a
c:0x20Z2e mov 0x19.a
c:0x2030 mov r13.a

current assemble address: C:0x201E
enter MCS-51 instiuction: Show symbols._. |
Aszzemble I
Close | Help |
Figure 14

Single Stepping

1)

2)
3)

4)

5)
6)

7)

dScope uses “ Step Into” to single step one instruction at atime. “Step Into” is also used to enter a
function in the same fashion.

“Step Over” means to skip over afunction that you are not interested in.

“Step Out™ isused to exit afunction you are currently in. “Step Out™ is very useful if you find
yourself in afunction you are not interested in and need to return quickly to your intended function.

If dScope gets stuck - do areset using the RESET box on the Toolbox or click on the button next to
the Help “?’, reload the file and/or the DLL. You can dso try the 8051.dll to isolate any problems
from the evaluation board. Y ou can aso use the hardware RESET button on the board.

With the cursor on line 42 click on StepInto until you enter the function Stepout. Note that you
must click on Steplnto 10 times to exit the loop.

Repeat the process using StepOver and you will not enter the function although it will be executed.
Thisis useful to skip function calls you are not interested in debugging.

Note that the StepOut button is grayed out and not availablein tScope. StepOut is available in the
simulator dScope and provides a quick escape from afunction by executing the next return
instruction.

Memory Window

1)
2)
3)

4)

The Memory Window shows as the default the data space starting at D:0x0000. Thisisthe area
where data variables are kept in this example.

Note that as you step through the program that the contents of the memory changes as the variable
values are adjusted.

Y ou can change the memory areawith the DISPLAY command in the Command window. Enter d
€:0x00 and the code area will be displayed.

Change back to the data area with d d:0x00
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Watch Window

1) The Watch Window displays memory contents as specified by their name. Structures can also be
displayed.

2) Open the Setup menu and select Watchpoints. In the Expr.: window, enter the following symbols
each then followed by clicking on Define watch. ::
bigcount, first, second and var. Notethat if you also select Oxnn the values will be displayed in
decimal rather than hexadecimal notation. Try thisfor one or two of the variables.

3) These variables will now be displayed in the Watchpoint windows.
4) Click on StepOver and the variable values will changes as appropriate.

5) Note: when are using dScope (i.e. the software debugger) and if in the Update Memory Window
and Update Watch Window (in the Setup menu) are activated - the variable values will change as
the program isrunning. Thisfeature is not possible with tScope running on a hardware board.

6) Open the Peripherals menu and select Configuration. Activate use serial interrupt and click on
Apply then Close.

7) DoaRESET and gtart over as before. Press GO and then STOP and note that the values changein
both the Watch and Memory windows when the processor is stopped.

Performance Analysis

This option displays the relative processor time spent in user specified modules. Thisfeatureis
available only in dScope and not on atarget board using tScope. Before beginning this section, close
dScope and return to uVision.

1) Theprogramislisted in Figure 15. It is called main.c.
2) Using nVision File menu, enter this program and save it as c:\c51eval\bin\main.c.

3) Open the Project menu and start a new project called keilex.prj. Add main.c to the project and
savethisinthe usua manner. Thisisillustrated in Figure 16.

4) Notethat no options need to be set as they are set with the #pragma statement in main.c.
5) Click on Build All.

6) Open dScope and close the Watch and Memory windows. Open the performance and Seria 1/0
windows and position similar to Figure 17 or to your own preferences.

7) Select the 8051.dll and the object file keilex. Remember you can not select mon51.dll.
8) Enter $=main in the Command Window. This step is optional but allows you to see the source.
9) Open the Setup menu and select Setup Performance Analyzer.

10) Enter the following function names in the Expr.: box::
indirect0, indirectl, indirect2 and main each followed by clicking on Define Range.

11) Close thiswindow.
12) Press GO and stand back !

13) The Serid Window displays some text and the Performance Analyzer will display threered lines
showing the relative processor time spent in each of the four modules.

14) Click on RESET in the Toolbox box and the process will start over.
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/* Siemens C504 example - David Lively,*/
/* main.c */

#pragma db oe sb cd

/* db == debug in OBJ */

/* oe == extended debug in OBJ */

/* sb == include synbols in OBJ */

/* cd == include assenbly code in LST */
#i ncl ude <reg51. h> */

#i ncl ude <stdio. h> */

#i nclude <stdlib.h> */

void indirectO(long d) {
| ong count =0;

f or (count =0; count <d; count ++) ;

}

void indirect1(long d) {
| ong count =0;

f or (count =0; count <d; count ++) ;

}

void indirect2(long d) {
| ong count =0;

f or (count =0; count <d; count ++) ;

void (*f)(long i); /* function pointer */
/* used to call a function at random */

void *farr[3] = {indirectO,indirectl,indirect2}; // array of function
addr esses
voi d mai n(void) {

| ong count =0;

/linitialize 8051 serial port

SCON = 0x50;
TMOD | = 0x20;
TH1 = 0Oxf 3;
TR1 = 1;
TI = 1;

srand(64); // reseed random nunber gener ator
tf("-- Start Execution -- \n");
e(1) {
f= farr[rand()%]; // pick a function at random
f(10000); // call the function and let it |oop
}

Figure 15
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CONCLUSION

What else is there ?

Plenty...

Open the Command option in the Debug window and notice you can select High Level Language,
assembler or both (mixed) to be displayed and the trace. Note the trace only works for software
simulation - tScope is unable to determine the actual bus valuesin your hardware.

Open View and note the many windows you can open such as Watchpoints, Register, Performance
Analysis and Code Coverage.

Open Peripheras and you can see windows illustrating values of 1/O Ports, Timers and counters.

Open the Setup window and you can set many options such as the Performance Anayzer, Register
sets, breakpoints and Watchpoints.

OnlineHelp isaso available.

An Application Note giving instructions on how to replace the RISM Eprom in the Intel evauation
board with your own code produced with Keil software. Get Application Note 111 from
www.keil.com

What is next ?

Plenty...
More sessions using C code will be prepared. More dScope features will be explored with more
sophisticated programs.
These will be available in October or November. Check www.keil.com/~market for further details.

For additiona information on Keil software development tools, visit the Keil web site at :
www.Keil.com. Check the Keil Marketing Group Web page at www.keil.com/~market for the latest in
software for the C504 Starter Kit or the latest version of this document

For more information regarding the entire Keil tool chain.....see the Help file Evalkit.hlp located in the
root of the Keil CD-ROM available free from Keil.

Any problems or questions ? Call us. We are here to help you with your Siemens C504 project.

Robert Boys, BBA, MIS, CMA

Shelley Potter, BBA, Marketing Assistant
Dallas, Texas

August 15, 1997
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Siemens Support from Keil Software Inc. Dallas, Texas

Keil Software develops, manufactures, and distributes embedded software development tools for the C501
and the C166 microcontroller families. Tools include C compilers, Assemblers, Real-time Executives,
Debuggers and Simulators, Integrated Environments, and Evaluation Boards. Keil has atraining facility
in Dallas for 8051 and 166 products. Keil provides distribution, product development, and technical
support from its office in Dallas, Texas.

Keil’sweb site [www.keil.com] provides the latest information about our development tools, demo
programs, software updates, application notes, example programs, and links to other sources of
information. Also see www2.keil.com for our latest Beta site.

C51 and C166 C Compiler for the entire 8051 family and the C166 Family

The C51 and C166 isafull ANSI C compiler with assembler. nVision isthe Windows User Interface that
drives the optimizing C51 and C166. The Compiler, Assembler and Linker options are point and click.
nmVision and the manuals are written in the USA and extensive on-line help isincluded. Free technical
support from Dallas viaa 1-800 line is included for one year.

A51, A51: Macro Assemblers for all Keil supported microcontrollers

These three Macro Assemblers are included with their respective Compiler package or are available
separately. All utilities needed to complete your project are included for all members of the assembler’s
family. These Assemblers are DOS based or can be run from nVision which isincluded with every
Assembler and Compiler package.

nVision Integrated Development Environment - Windows based User Interface.

nVision isa USA developed Windows-based front end for all Keil Compilers and Assemblers. It includes
an editor, project manager, and make facility. Compiler, assembler, and linker options are set by pointing
and clicking on prompted selections. Program Manager conveniently accesses your files, and 3 party
executables and also calls the Keil Simulator dScope easing the transition from utility to utility. Works
with Windows 3.11, 95 and NT.

dScope-Debugger and Simulator for the 8051 and 166. Windows or DOS based.

dScope is a source-level debugger that lets you debug programs created by Keil compilers. dScope
simulates your program either in stand-alone mode or in your target using the monitor. External
hardware, signals, and interrupts can be simulated. Viewable windows include View Program from 1/O,
Trace, Stack, Watch and CPU registers plus more.

TR51/FR51/FR166 Full-Function RTOS for the entire 8051 and 166 families

The RTX51 and RTX166 are a multitasking Real-time Operating Systems for the entire 8051 and 166
families. This powerful tool lets you manage multiple tasks on a single CPU. The RTX51 Full and
RTX166 FULL includes CAN libraries. The RTX51 Tiny isasubset of the RTX51 Full as are the 166
versions. Functions include interrupt and memory management, clock, and semaphores. Royalty-free.
CAN Library

The RTX51 and RTX166 Full RTOS supports CAN controllers with the included libraries. The CAN
libraries are sold with the RTOS. The CAN interface is becoming popular for automotive and industrial
markets. 11 and 29 bit identifiers are supported. Keil 8051 C compilers interface with the RTOS and
CAN libraries. Keil supportsal CAN microcontrollers based on the Siemens C515C, C505C, C167CR
the Philips 592 and the Intel 526 and 527.

Upgrades

Free updates for Keil compilers are available from the Web to registered users. Special upgrade prices are
available for selected Franklin and Archimedes compilers. Call Keil for details on how to save money
using this special program.

Keil Software phone (800) 348-8051
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